• 0
maarc93

nesanāk instalēt php5-mysqlnd

Question

izdarīju kļūdu - izpidlīju apt-get remove php5-mysql, jo gribēju ieinstalēt php5-mysqlnd, bet pēc komandas izpildas rāda šo:

 

 

root@priede:/etc/php5/mods-available# apt-get install php5-mysqlnd

Reading package lists... Done

Building dependency tree       

Reading state information... Done

The following packages were automatically installed and are no longer required:

  libvpx1 php7.1-common php7.1-mysql

Use 'apt-get autoremove' to remove them.

The following extra packages will be installed:

  libapache2-mod-php5 libgd3 libwebp5 php5-cgi php5-cli php5-common php5-curl

  php5-fpm php5-gd php5-mcrypt php5-readline php5-sqlite

Suggested packages:

  libgd-tools php5-user-cache

The following NEW packages will be installed:

  libwebp5 php5-mysqlnd

The following packages will be upgraded:

  libapache2-mod-php5 libgd3 php5-cgi php5-cli php5-common php5-curl php5-fpm

  php5-gd php5-mcrypt php5-readline php5-sqlite

11 upgraded, 2 newly installed, 0 to remove and 191 not upgraded.

Need to get 11.7 MB/11.9 MB of archives.

After this operation, 1,134 kB of additional disk space will be used.

Do you want to continue? [Y/n] y

WARNING: The following packages cannot be authenticated!

  php5-readline php5-cli php5-mcrypt php5-fpm php5-curl php5-sqlite php5-gd

  php5-cgi libapache2-mod-php5 php5-common php5-mysqlnd

Install these packages without verification? [y/N] y

Err http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/trusty/main php5-readline amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1

  404  Not Found

Err http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/trusty/main php5-cli amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1

  404  Not Found

Err http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/trusty/main php5-mcrypt amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1

  404  Not Found

Err http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/trusty/main php5-fpm amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1

  404  Not Found

Err http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/trusty/main php5-curl amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1

  404  Not Found

Err http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/trusty/main php5-sqlite amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1

  404  Not Found

Err http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/trusty/main php5-gd amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1

  404  Not Found

Err http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/trusty/main php5-cgi amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1

  404  Not Found

Err http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/trusty/main libapache2-mod-php5 amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1

  404  Not Found

Err http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/trusty/main php5-common amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1

  404  Not Found

Err http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/trusty/main php5-mysqlnd amd64 5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1

  404  Not Found

E: Failed to fetch http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-readline_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 404  Not Found

 

E: Failed to fetch http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-cli_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 404  Not Found

 

E: Failed to fetch http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-mcrypt_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 404  Not Found

 

E: Failed to fetch http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-fpm_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 404  Not Found

 

E: Failed to fetch http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-curl_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 404  Not Found

 

E: Failed to fetch http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-sqlite_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 404  Not Found

 

E: Failed to fetch http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-gd_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 404  Not Found

 

E: Failed to fetch http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-cgi_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 404  Not Found

 

E: Failed to fetch http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/libapache2-mod-php5_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 404  Not Found

 

E: Failed to fetch http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-common_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 404  Not Found

 

E: Failed to fetch http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/pool/main/p/php5/php5-mysqlnd_5.6.23+dfsg-1+deprecated+dontuse+deb.sury.org~trusty+1_amd64.deb 404  Not Found

 

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

 

Ubuntu 14.04. PHP versija - 5.6.29-1+deb.sury.org~trusty+1 (cli). Tagad nevaru caur php pieslēgties mysql. Ko darīt? Nevaru ieinstalēt php5-mysql, gan php5-mysql

Edited by maarc93

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

izdzēsu vecos PPA, pievienoju jaunu (add-apt-repository ppa:ondrej/php) , uztaisīju apt-get update, tad apt-get install php5-mysql, bet rāda šo:

 

 

root@priede:/usr/lib/php5/20131226# apt-get install php5-mysql

Reading package lists... Done

Building dependency tree       

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

 

The following packages have unmet dependencies:

 php5-mysql : Depends: phpapi-20121212

              Depends: php5-common (= 5.5.9+dfsg-1ubuntu4.20) but 5.6.17+dfsg-1+deb.sury.org~trusty+1 is to be installed

E: Unable to correct problems, you have held broken packages.

Share this post


Link to post
Share on other sites
  • 0

Nu te ir cita problēma.. googlē vien tālāk :)

Share this post


Link to post
Share on other sites
  • 0

apt-get install php5.6-mysql

Share this post


Link to post
Share on other sites
  • 0

Hmm, bet man vajag priekš php5, nevis php5.6. Komanda "apt-get install php5.6-mysql" instalē priekš php5.6

/etc/ izskatās šādi:

15_screenshot2017-01-11at22.18.38.png

Edited by maarc93

Share this post


Link to post
Share on other sites
  • 0

Tad vispirms izdomā, kuru php versiju gribēsi, jo pēc taviem postiem to nevar saprast.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now