Jump to content
php.lv forumi

phpmyadmin


hackerman
 Share

Recommended Posts

Ir tāda lieta, ka mana dautbāze aizņem vairāk nekā atļauts uploadot caur manu phpmyadminu. (skat. att.)

11834716.jpg

 

Manam hostingam var uploadot ~8mb, bet es uz savu phpmyadminu varu tikai ~2mb

Kā var mainīt to limitu?

 

P.S. Es pačekoju failu config.inc.php, bet tur neatradu, vai arī paaidu garām...

Link to comment
Share on other sites

Vai tad max_upload_size neattiecas uz piemeeram, atteelu uploadoshanu?

 

Vinsh tachu laikam grib tracsfereet datus?

 

 

MySQL manuaalis:

 

A.2.9. Packet too large

A communication packet is a single SQL statement sent to the MySQL server or a single row that is sent to the client.

 

The largest possible packet that can be transmitted to or from a MySQL 5.0 server or client is 1GB.

 

When a MySQL client or the mysqld server receives a packet bigger than max_allowed_packet bytes, it issues a Packet too large error and closes the connection. With some clients, you may also get a Lost connection to MySQL server during query error if the communication packet is too large.

 

Both the client and the server have their own max_allowed_packet variable, so if you want to handle big packets, you must increase this variable both in the client and in the server.

 

If you are using the mysql client program, its default max_allowed_packet variable is 16MB. To set a larger value, start mysql like this:

 

mysql> mysql --max_allowed_packet=32M

 

That sets the packet size to 32MB.

 

The server's default max_allowed_packet value is 1MB. You can increase this if the server needs to handle big queries (for example, if you are working with big BLOB columns). For example, to set the variable to 16MB, start the server like this:

 

mysql> mysqld --max_allowed_packet=16M

 

You can also use an option file to set max_allowed_packet. For example, to set the size for the server to 16MB, add the following lines in an option file:

 

[mysqld]

max_allowed_packet=16M

 

It is safe to increase the value of this variable because the extra memory is allocated only when needed. For example, mysqld allocates more memory only when you issue a long query or when mysqld must return a large result row. The small default value of the variable is a precaution to catch incorrect packets between the client and server and also to ensure that you do not run out of memory by using large packets accidentally.

 

You can also get strange problems with large packets if you are using large BLOB values but have not given mysqld access to enough memory to handle the query. If you suspect this is the case, try adding ulimit -d 256000 to the beginning of the mysqld_safe script and restarting mysqld.

Edited by zxspectrum
Link to comment
Share on other sites

diivaini... es biju domaajis, ka datu importeesana/eksporteesana phpmyadminaa notiek kveeriju veidaa... laikam tachu buushu dazhas reizes saglabaajis savus datus, eksporteejot uz savu kompi sql faila veidaa... un atpakalj. tur veel rakstiits Max file siz 2048 KB. un, kad mana faila izmeers jau paarsniedza tos atljautos 2MB, shitaa vietinja man paliidzeeja... uzliku uz 8 MB un laadeeju taalaak.

 

 

" Tas attiecas uz jebkuru uploadējamo failu, ne tikai uz attēliem." - Tu saki.

 

Vai datu imports/eksports == uploads?

Link to comment
Share on other sites

To par to attiekšanos es attiecināju uz "Vai tad max_upload_size neattiecas uz piemeeram, atteelu uploadoshanu?"

 

Un tie 2 mb tur phpmyadmin nāk no php konfigurācijas. (2MB ir defaultā vērtība vispār). Vai tad tev neliekas, ka pirms sql faila importēšanas mysql serverī, tie vispirms ir jāuploadē uz servera ? Un ja to dara ar php, tad php ierobežojumi arī strādā.

Edited by andrisp
Link to comment
Share on other sites

 Share

×
×
  • Create New...