Jump to content
php.lv forumi

Recommended Posts

Sveiki! Maklēju palīdzību. Ir mājas lapa, kura būvētu uz WordPress. WordPress sūta paziņojumu, ka jāizvēlas PHP vismaz 7.3 (esošais lapas PHPir 7.1). Saprotu tikai tādā līmenī, ka paskatījos video Youtube un izdarīju visu kā rādīja. Tomēr lapa nestrādāja. Pārbaudīju visus plaginus, tur nebija vaina. Nekādu kļūdu neizmeta, bet novirzīja uz šādu lapu palasīties: https://wordpress.org/support/article/debugging-in-wordpress/

Share this post


Link to post
Share on other sites

Pirmais, kas jādara, ir jāieslēdz visu erroru rerpotings (google enable error reporting php/wordpress), ir jāatrod servera error logi (PHP) un jāmeklē, kas tieši nestrādā.

Share this post


Link to post
Share on other sites

Domājams, ka no sākuma vajadzētu definēt, kur tu mēģini izvietot Wordpress. Būtībā, jautājums ir vai tas ir kaut kāds VPS, vai shared hosting, vai vienalga. Pēc tam jāturpina ar PHP versiju, jo izskatās, ka tāda ir Wordpress rekomendācija - https://wordpress.org/about/requirements/ .

Share this post


Link to post
Share on other sites

Izmeta šo:

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home3/evija/public_html/wp-includes/wp-db.php:1658 Stack trace: #0 /home3/evija/public_html/wp-includes/wp-db.php(631): wpdb->db_connect() #1 /home3/evija/public_html/wp-includes/load.php(426): wpdb->__construct('evija_wp323', '38S0pxpb[-', 'evija_wp323', 'localhost') #2 /home3/evija/public_html/wp-settings.php(126): require_wp_db() #3 /home3/evija/public_html/wp-config.php(102): require_once('/home3/evija...') #4 /home3/evija/public_html/wp-load.php(37): require_once('/home3/evija...') #5 /home3/evija/public_html/wp-blog-header.php(13): require_once('/home3/evija...') #6 /home3/evija/public_html/index.php(17): require('/home3/evija...') #7 {main} thrown in /home3/evija/public_html/wp-includes/wp-db.php on line 1658

Share this post


Link to post
Share on other sites

Izskatās, ka mysql extension's nav ieslēgts PHP.

Google: "wordpress php enable mysql extension"

 

Piezīme: kad šēro koda fragmentus, dari to uzmanīgi, lai nenopludināti sensitīvu informāciju. Tev tur parole iekļauta...

image.png.20df4ba4e4c77e98ff8b5fe31d5c0cbc.png

Ja to pašu paroli lieto publiskajā wordpress lapā, iesaku nomainīt.

Share this post


Link to post
Share on other sites

Forumu labā etiķete prasa, lai arī padalies ar risinājumu, ja nu kāds nonāk pie līdzīgas problēmas, lai zina, kas bija jādara :)

Share this post


Link to post
Share on other sites

Sorry! CPanel izvēlas Select PHP Version, nomaina PHP versiju uz 7.3 un uzstādījumos ielik iztrūkstošo ķeksi pie mysqli.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...