Jump to content
php.lv forumi

Par PHP5


Recommended Posts

Pie tam, rakstot selektus, ieteicams izmantot EXPLAIN keywoardu, ar to var noteikt vai/un kādas primārās atslēgas SQLite izmantos meklējot datus. Tādējādi var nedaudz pielabot savu SQL kodu, lai tas tomēr izmantot šīs atslēgas (neizmantojot indeksus darbības laiks ir O(n), bet izmantojot - O(log n)). Līdzīgas nozīmes keywoards ir arī MySQL..

Link to post
Share on other sites

Laikam nederes, jo tur tiek izmantots searchs ar like. Un selekti, tur ir ar left joiniem ;) Nu ok, shaja gadijuma nederes sqlite, bet domaju, ka turmak atradishu pielietojumu :)

 

Man agrk bija problemas iemacities sql, jo man mysql.com manualis nepatiik, tapec tagad izmantoju pats savu, un tur var daudz atrak atrast, ja lieto firefoxam ctrl+F mysql-man

Link to post
Share on other sites

Tas nekas, left joini nav nekas traks.

Īsti nesaprotu tava manuāļa jēgu.. Vai tad tas nav tas pats, kas šis: http://dev.mysql.com/get/Downloads/Manual/...t.zip/from/pick ?? Un kam searchs mysql onlaina manuālī domāts ;))

Es gan izmantoju CHM formātu, man kautkā tas liekas ērtāks. Un ar šo tūli: http://phlab.net/myman/ vienmēr var no jaunākā .html failu kolekcijas mysql manuālim to uztaisīt.

Link to post
Share on other sites

Nu jēga ir tieši tāda pati, kā tam ko tu izmanto :) Es esmu uz linuxa un te CHM formātu man īsti negrib ņemt pretī, tb. tā proga kas to dara ir pilna ar vabolem.

 

- - -

Šausmīgi gribētu uz sava darba servera PHP5, bet problēma ir tajā, ka tur jau ir kādas 3-4 web lapas, kuras ir uz PHP4. Nu ja uzlikshu, tad bus jalieto mysqli jo ir 4.1 versija, te nebūtu problēma, paņem visur mysql repleiso ar mysql. Bet ko darīt ar OOP? Vai tur tiešām neko nevar darīt?

Edited by Gacha
Link to post
Share on other sites
Šausmīgi gribētu uz sava darba servera PHP5, bet problēma ir tajā, ka tur jau ir kādas 3-4 web lapas, kuras ir uz PHP4.

Nu var jau uz viena servera darbināt gan PHP4 gan PHP5.

Proti vienu darbina kā DSO moduli otru kā CGI.

1) vai nu izmantojot dažādus failu paplašinājumus teiksim .php5 pārsēt ar php5 moduli

2) vai ērtāk savām vajadzībām izveidot virtualhostu kurā definējam ka .php pārsējas ar php5 moduli

Link to post
Share on other sites

bubu: mysql 4.1 jau ir uz ta servera, tapec nav izveles.

 

Roze: Tas 2 variants izklausas ideals variants, varbūt pastāsti mazliet tuvāk par to. Vai ir pašam pieredze šajā lieta? Vai viss iet kā tam jaiet, vai var būt problēmas?

Link to post
Share on other sites
  • 3 weeks later...
Sveiki!

Man interesē, kā ir ar PHP5! Vai kāc to reāli izmanto ejošiem projektiem? Un cik lielā mērā? Vai vadošās hosting firmas Latvijā un pasaulē to atbalsta?

13722[/snapback]

 

Pēdējā laikā biju veicis nelielu šo hostinga provaideru aptauju, lai savāktu informāciju par pieejamo tehnisko bāzi. Visos manis apjautātajos uzņēmumos tika izmantots PHP 4.*.*, galvenokārt 4.3.9 vai 4.3.10.

Link to post
Share on other sites
  • 4 months later...

uz popular.lv servera var hosteeties uz PHP 5... tas taa atkaapei.

uz Servera domaaju ka php 4 pret php5 var mieriiigi mainiit.

vari palaist gan mysql4 gan mysql5, tik piespeedz attieciigos moduljus un viss buus 4ikii :)

Link to post
Share on other sites
×
×
  • Create New...