Jump to content
php.lv forumi
Sign in to follow this  
Eob

Ruby on Rails + XAMPP iekš Ubuntu

Recommended Posts

Lieta tāda, ka paralēli XAMPP (a.k.a LAMPP) uz Ubuntu 10.10 nepieciešams uzstādīt un padarīt gatavu darbam Ruby on Rails (pilnu komplektu ar visiem tur tiem darbam vajadzīgajiem pribambasiem).

Tā kā no RoR vēl ne velna nejēdzu, tad pašam nav ne jausmas kam un kā tur ir jābut un uzticēšos padomiem par to, kas un kā ir labāk un pareizāk.

Mērķis ir iegūt darbam gatavu Ruby on Rails editoru (vai nu hvz kā to varētu nosaukt - tjip, lai var ņemt un mācities) tajā pašā laikā nenograujot jau esošo XAMPP web serveri.

Izmantoju Ubuntu 10.10 Linux, bet ja iekš Ubuntu tas nav izdarāms, pieejams ir arī Windows 7.

 

Tātad, ir kādi ieteikumi, kā to dabūt gatavu? Iekš Googles šo to uzraku, bet sekojot instrukcijām, XAMPP pēc tam vairs nestrādā un par to, vai RoR strādā nezinu, jo nav ne jausmas, kā tam ir jāizskatās.

 

 

Mož šī nav īstā vieta, kur šo tēmu veidot, bet piemērotāku vietu nevarēju ieraudzīt. Ceru uz kādu nebūt palīdzību. :)

Share this post


Link to post
Share on other sites

Izmanto RVM lai uzinstalētu jaunāko Ruby versiju - http://beginrescueend.com/

 

gem install rails

 

http://guides.rubyonrails.org/getting_started.html sākot no punkta 3

 

RoR nāk ar iebūvētu web serveri ar kuru tev iesākumam būs gana...un viņš by default izmanto 3000 portu tātad nekonfliktēs ar Apache.

 

Un izmanto Unix nevis Windows...

Share this post


Link to post
Share on other sites

Tātad, man ir XAMPP iekš Ubuntu (vēl joprojām strādā) un ar apt-get install rails instalēts Rails (cik noprotu, iesākumam vajadzētu pietikt). Lai izveidotu kādu nebūt datubāzi vajadzēs atseviški instalēt kādu nebūt SQL, vai tajā manis instalētajā Rails pakā jau ir iekļauts viss nepieciešamais, lai izveidotu datubāzi? Instalējot kaut ko no SQL, visticamāk, XAMPP pārstās strādāt (nu, vismaz cik iepriekš mēģināju, tā notika).

Share this post


Link to post
Share on other sites

Pamēģini šādi, pats nekad neesmu mēģinājis, bet moš strādā.

Ieinstalē xampp un ruby on rails bez mysql. Pēctam rails aplikācijā sakonfigurē database.yml, lai aplikācija izmantotu xampp datubāzi.<pre>

socket: /opt/lampp/var/mysql/mysql.sock

Bet, ja tomēr ieinstalējās rails ar mysql un xampp vairs nevar palaist, jau fonā esoša mysql processa dēļ, tad apstādini to ar

sudo /etc/init.d/mysql stop

un restartē xampp.</pre>

Edited by entu

Share this post


Link to post
Share on other sites

Es neieteiktu instalēt caur apt-get, jo tur ne vienmēr būs jaunākā versija (gan gems'am gan rails'am) un mainīt versijas IMO nebūs tik viegli. Manuprāt vislabāk ir to visu darīt salīdzinoši manuāli kā jau es ipriekšējā postā minēju...

 

Un rails nenāk pre-instalēts ar mysql bundle'i (nezinu kas notiek caur pakotņu menedžeriem gan) tā kā varēsi izmantot esošo lampp mysql versiju.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...